Обновление php 5.2.6 до php 5.2.17



Необходимо было обновить php 5.2.6 до php 5.2.17 на Дебиан 5.0. Перерыв кучу ссылок в интеренете, не нашел ничего полезного за сайта dotdeb.org. Очень полезный ресурс. Но к сожалению обновиться до php 5.2.17 он не дает в автоматическом режиме. Поэтому нужно скачивать все пакеты я сделал это через скрипт он приведен ниже

#!/bin/sh
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/libapache2-mod-php5filter_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/libapache2-mod-php5_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5_5.2.17-0.dotdeb.0_all.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php-pear_5.2.17-0.dotdeb.0_all.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-cgi_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-cli_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-common_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-curl_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-dbg_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-dev_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-gd_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-gmp_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-imap_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-interbase_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-ldap_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-mcrypt_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-mhash_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-ming_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-mysql_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-odbc_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-pgsql_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-pspell_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-recode_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-sqlite_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-sybase_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-tidy_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-xmlrpc_5.2.17-0.dotdeb.0_amd64.deb
wget http://archives.dotdeb.org/dists/lenny/php5/5.2.17/binary-amd64/php5-xsl_5.2.17-0.dotdeb.0_amd64.deb

и потом установить эти самые пакеты
dpkg -i libapache2-mod-php5filter_5.2.17-0.dotdeb.0_amd64.deb libapache2-mod-php5_5.2.17-0.dotdeb.0_amd64.deb php5_5.2.17-0.dotdeb.0_all.deb php-pear_5.2.17-0.dotdeb.0_all.deb php5-cgi_5.2.17-0.dotdeb.0_amd64.deb php5-cli_5.2.17-0.dotdeb.0_amd64.deb php5-common_5.2.17-0.dotdeb.0_amd64.deb php5-curl_5.2.17-0.dotdeb.0_amd64.deb php5-dbg_5.2.17-0.dotdeb.0_amd64.deb php5-dev_5.2.17-0.dotdeb.0_amd64.deb php5-gd_5.2.17-0.dotdeb.0_amd64.deb php5-gmp_5.2.17-0.dotdeb.0_amd64.deb php5-imap_5.2.17-0.dotdeb.0_amd64.deb php5-interbase_5.2.17-0.dotdeb.0_amd64.deb php5-ldap_5.2.17-0.dotdeb.0_amd64.deb php5-mcrypt_5.2.17-0.dotdeb.0_amd64.deb php5-mhash_5.2.17-0.dotdeb.0_amd64.deb php5-ming_5.2.17-0.dotdeb.0_amd64.deb php5-mysql_5.2.17-0.dotdeb.0_amd64.deb php5-odbc_5.2.17-0.dotdeb.0_amd64.deb php5-pgsql_5.2.17-0.dotdeb.0_amd64.deb php5-pspell_5.2.17-0.dotdeb.0_amd64.deb php5-recode_5.2.17-0.dotdeb.0_amd64.deb php5-snmp_5.2.17-0.dotdeb.0_amd64.deb php5-sqlite_5.2.17-0.dotdeb.0_amd64.deb php5-sybase_5.2.17-0.dotdeb.0_amd6.deb php5-tidy_5.2.17-0.dotdeb.0_amd64.deb php5-xmlrpc_5.2.17-0.dotdeb.0_amd64.deb php5-xsl_5.2.17-0.dotdeb.0_amd64.deb

после чего у вас будет php 5.2.17. Удачного обновления!

Share and Enjoy:
  • Мой Мир
  • Facebook
  • Twitter

Related posts:

  1. Решение проблемы с gd в Дебиан

Вы можете пропустить чтение записи и оставить комментарий. Размещение ссылок запрещено.

Оставить комментарий

Вы должны быть авторизованы, чтобы разместить комментарий.